Back to overview
Resolved
plex.home.robbiecrash.me and Movie Updates are down
Aug 22, 2026 at 4:31am UTC
Affected services
plex.home.robbiecrash.me
Movie Updates
Resolved
Aug 22, 2026 at 4:38am UTC
Movie Updates recovered.
Affected services
Updated
Aug 22, 2026 at 4:36am UTC
plex.home.robbiecrash.me recovered.
Affected services
Created
Aug 22, 2026 at 4:31am UTC
Movie Updates went down and plex.home.robbiecrash.me is degraded.
Affected services