Back to overview
Resolved
plex.home.robbiecrash.me, TV Updates, and 2 other services are down
Jul 14, 2026 at 2:28am UTC
Affected services
plex.home.robbiecrash.me
TV Updates
Movie Updates
Downloads
Resolved
Jul 14, 2026 at 2:34am UTC
Movie Updates recovered.
Affected services
Updated
Jul 14, 2026 at 2:32am UTC
plex.home.robbiecrash.me recovered.
Affected services
Updated
Jul 14, 2026 at 2:30am UTC
TV Updates and Downloads recovered.
Affected services
Created
Jul 14, 2026 at 2:28am UTC
TV Updates, Movie Updates, and Downloads went down and plex.home.robbiecrash.me is degraded.
Affected services